Jump to content

Recommended Posts

1 hour ago, SCC said:

@M1995 Did you apply as a special/Aboriginal applicant? I don't have the references or supporting documents sections on my portal (I applied as a regular applicant).

Neither did I. 

Share this post


Link to post
Share on other sites
2 hours ago, M1995 said:

Hey I’m really confused with the application system. My transcript section is green and seems to be updated to include my winter grades May 15. But my: 

LSAT 

REFERENCES

SUPPORTING DOCUMENTS

are all in red and have nothing beside them. I didn’t submit any references. Is this normal or? 

Try using the dialogue box on the right-hand side of the page. In my experience, if the question can be answered via the "message of the day" they will just direct you to that. Had some documents go missing (either in the mail or at their office, no idea) and was never told. Only course of action was to submit another set.

Share this post


Link to post
Share on other sites

Thanks everyone, apparently I signed up as a special applicant. It was my bad so I asked them to transfer me over to the regular category. Thanks! 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×